Access to MyCase
Incident Report for MyCase - Public
Resolved
Access to MyCase should be fully restored for all users. Please reach out to support@mycase.com if you continue to encounter any issues.
Posted 9 months ago. Jan 21, 2019 - 09:48 PST
Update
We are continuing to investigate this issue.
Posted 9 months ago. Jan 21, 2019 - 09:47 PST
Investigating
MyCase is currently experiencing some intermittent connection issues, and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted 9 months ago. Jan 21, 2019 - 09:44 PST