Access to MyCase - Intermittent Issues
Incident Report for MyCase - Public
Resolved
MyCase is fully operational as of 3:00pm PST. There was a short period starting at approximately 2:30pm until 3:00pm where some users may have experienced intermittent connectivity errors or access issues.
Posted 12 months ago. Aug 24, 2018 - 15:20 PDT
Update
We are continuing to investigate this issue.
Posted 12 months ago. Aug 24, 2018 - 15:13 PDT
Investigating
MyCase is currently experiencing some intermittent connection issues, and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted 12 months ago. Aug 24, 2018 - 14:52 PDT