Access to MyCase
Incident Report for MyCase - Public
Resolved
The MyCase service has been fully restored. Thank you for your patience.
Posted about 1 year ago. Sep 21, 2018 - 17:51 PDT
Update
Our engineers are currently implementing a solution to restore service. Thank you for your patience we will continue to post updates to this page.
Posted about 1 year ago. Sep 21, 2018 - 17:02 PDT
Update
We continue to work as quickly as we can to restore the MyCase service availability. We will continue to update this page.
Posted about 1 year ago. Sep 21, 2018 - 15:50 PDT
Update
We continue to work to restore service and will provide additional information here as it becomes available.
Posted about 1 year ago. Sep 21, 2018 - 14:39 PDT
Update
We have identified the issue and are actively working to restore service. We will contintue to provide updates as more information is available.
Posted about 1 year ago. Sep 21, 2018 - 13:25 PDT
Update
Our engineers are working towards a resolution to restore full access to Mycase as soon as possible. We will provide updates as more information is available.
Posted about 1 year ago. Sep 21, 2018 - 12:53 PDT
Identified
We are experiencing issues with our site. Engineering is aware of the problem and working on a resolution. We will provide updates as soon as more information is available.
Posted about 1 year ago. Sep 21, 2018 - 11:55 PDT
This incident affected: MyCase.