Dropbox Integration
Incident Report for MyCase - Public
Resolved
Our Dropbox integration is now available. We apologize for any inconvenience.
Posted Mar 04, 2020 - 19:03 PST
Investigating
Our Dropbox integration is currently unavailable. Our engineering team is working to re-enable this integration as soon as possible. You will be able to access any documents directly through your dropbox account.
Posted Mar 04, 2020 - 14:49 PST
This incident affected: Integrations.