MyCase Credit Card Payments
Incident Report for MyCase - Public
Resolved
Our credit card processor has let us know that they have resolved the issue. Thank you for your patience while this was being fixed.
Posted 6 months ago. Mar 06, 2019 - 11:19 PST
Identified
Our credit card processor has let us know that they have identified the issue and are working to resolve it. Thank you for your patience, we will continue to post updates to this page.
Posted 6 months ago. Mar 06, 2019 - 10:49 PST
Investigating
We are currently seeing a number of credit card transaction failures. Please try your payment again or wait until later today to make the payment. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted 6 months ago. Mar 06, 2019 - 10:04 PST
This incident affected: MyCase Credit Card Payments.