MyCase Payments - eCheck Unavailable
Incident Report for MyCase - Public
Resolved
The MyCase Payments eCheck functionality is now operational and available to use.
Posted Sep 06, 2022 - 08:57 PDT
Investigating
The MyCase Payments eCheck functionality is not currently available. This does not impact those using MyCase LawPay integration.
Posted Sep 06, 2022 - 08:47 PDT
This incident affected: MyCase eCheck Payments.