Degraded Performance with MyCase Search
Incident Report for MyCase - Public
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 16:40 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2024 - 13:54 PDT
Identified
The issue has been identified and several fixes are being implemented. Users should see some improvement as we continue to resolve.
Posted Mar 19, 2024 - 13:26 PDT
Update
We are continuing to investigate this issue.
Posted Mar 19, 2024 - 13:11 PDT
Investigating
MyCase is currently experiencing degraded performance of the Search feature resulting in slowness. Our Development Team is aware of this issue and working as quickly as possible to resolve it.
Posted Mar 19, 2024 - 12:38 PDT
This incident affected: MyCase.