Deleting/Editing Certain Records Within MyCase
Incident Report for MyCase - Public
Resolved
Our Development Team has resolved the issue. Thank you for your patience while this was being fixed.
Posted about 2 months ago. Jul 03, 2019 - 19:20 PDT
Update
Our Development Team is continuing to work to resolve this issue. We will update this status as more information becomes available.
Posted about 2 months ago. Jul 03, 2019 - 18:06 PDT
Identified
Some users are currently not able to delete or edit certain records within MyCase. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted about 2 months ago. Jul 03, 2019 - 17:03 PDT
This incident affected: MyCase.