Access to MyCase
Incident Report for MyCase - Public
Resolved
The MyCase service has been fully restored. Thank you for your patience.
Posted May 25, 2022 - 09:23 PDT
Monitoring
The MyCase engineering team has restored all services and is actively working to ensure performance is back to normal standards. Please continue to watch this page for updates.
Posted May 25, 2022 - 09:20 PDT
Investigating
MyCase is currently experiencing some intermittent connection issues, and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted May 25, 2022 - 09:05 PDT
This incident affected: MyCase.