Outage - MyCase eCheck Payments
Incident Report for MyCase - Public
Resolved
eCheck service has been restored.
Posted Dec 17, 2019 - 19:30 PST
Identified
Our payments provider has acknowledged the outage and is working to correct the issue.
We will continue to work with them to restore eCheck service as soon as possible.
Posted Dec 17, 2019 - 18:42 PST
Investigating
MyCase eCheck Payments are currently unavailable due to an issue with our third-party payments processor.

We are working to restore eCheck functionality as quickly as possible, and will update this page as the situation develops.
Posted Dec 17, 2019 - 17:15 PST
This incident affected: MyCase eCheck Payments.