MyCase Degraded Performance Due to Amazon Web Services Outage
Incident Report for MyCase - Public
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 15:26 PDT
Monitoring
A fix was implemented by the Amazon team and we are monitoring the results.
Posted Jun 13, 2023 - 14:40 PDT
Update
It seems that Amazon Web Services has recovered. We will continue to monitor closely.
Posted Jun 13, 2023 - 14:04 PDT
Update
MyCase and some of it's features may have degraded performance for some customers due to a partial outage of our cloud computing provider, Amazon Web Services.
Posted Jun 13, 2023 - 13:33 PDT
Investigating
The MyCase eCheck feature is currently experiencing disruption for some customers due to a partial outage of our cloud computing provider, Amazon Web Services.
Posted Jun 13, 2023 - 12:50 PDT
This incident affected: MyCase and MyCase eCheck Payments.