Degraded Multi Factor Authentication Performance- Text Messages

Incident Report for MyCase - Public

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 08:18 PDT

Monitoring

MFA text messages from our third party texting partner are functioning. We continue to monitor their delivery status.
Posted Apr 22, 2025 - 07:23 PDT

Investigating

We are currently investigating this issue with our third party texting partner. While MFA texts may fail for some customers, using email to login will work. If you need to switch email for MFA, please reach out to your admin user to reset this feature.
Posted Apr 22, 2025 - 06:41 PDT
This incident affected: MyCase.