Access to MyCase
Incident Report for MyCase - Public
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 14:34 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2024 - 13:53 PST
Update
The network provider is continuing to work on a solution. We will provide updates as soon as we receive them.
Posted Mar 05, 2024 - 13:47 PST
Identified
The issue has been identified with an external network provider in California. Currently only California users are being affected. The network provider is aware of the problem and working on a solution.
Posted Mar 05, 2024 - 13:17 PST
Investigating
MyCase is currently experiencing some intermittent connection issues, and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page and we will provide an update shortly.
Posted Mar 05, 2024 - 12:45 PST
This incident affected: MyCase.