Access to MyCase

Incident Report for MyCase - Public

Resolved

MyCase is now operating normally; we are closely monitoring performance.
Posted Sep 02, 2021 - 15:13 PDT

Monitoring

The issue has been resolved and we are monitoring to ensure normal system performance.
Posted Sep 02, 2021 - 15:05 PDT

Investigating

MyCase is currently experiencing connection issues and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted Sep 02, 2021 - 14:57 PDT
This incident affected: MyCase.