Client Portal is currently unavailable
Incident Report for MyCase - Public
Resolved
The Client Portal is now functioning normally.
We apologize for the inconvenience and appreciate your patience as we worked to resolve the issue.
Posted 9 months ago. Jan 30, 2019 - 06:58 PST
Investigating
Users are currently not able to log into the client portal. We are investigating this issue and working to return functionality as soon as possible. We will update this status as more information becomes available
Posted 9 months ago. Jan 30, 2019 - 06:12 PST
This incident affected: MyCase.