MyCase Payments Access
Incident Report for MyCase - Public
Resolved
Full access to MyCase Payments has been restored. Our teams will continue to monitor. We apologize for any inconvenience this may have caused.
Posted Jul 22, 2021 - 10:14 PDT
Investigating
We are aware of an issue with MyCase payment processing affecting some customers. Our engineers are actively working to resolve the issue. We will provide updates as soon as more information is available.
Posted Jul 22, 2021 - 09:48 PDT
This incident affected: MyCase Credit Card Payments.