Client Portal
Incident Report for MyCase - Public
Resolved
The Client Portal is now functioning normally.
We apologize for the inconvenience and appreciate your patience as we worked to resolve the issue.
Posted 8 days ago. Sep 13, 2019 - 14:14 PDT
Investigating
Some users may not be able to log into the client portal. We are investigating this issue and working to return functionality as soon as possible. We will update this status as more information becomes available
Posted 8 days ago. Sep 13, 2019 - 13:54 PDT
This incident affected: MyCase.