Access to MyCase
Incident Report for MyCase - Public
Resolved
A fix has been implemented, and the incident is now resolved.
Posted Sep 29, 2023 - 07:04 PDT
Update
The MyCase app is fully functional and all features are operational. Occasional slowness may still occur for several hours until our web service provider gets back to full capacity.
Posted Sep 28, 2023 - 16:37 PDT
Monitoring
A fix has been implemented and we are monitoring the results. Any remaining performance degradation should be fully resolved within the next 1-2 hours.
Posted Sep 28, 2023 - 15:19 PDT
Update
We are seeing significant improvement but intermittent connection issues and degraded performance continue for some users. Our web service provider has identified the core problem and is implementing a complete solution. They expect full resolution in the next 1-2 hours.
Posted Sep 28, 2023 - 14:41 PDT
Identified
The issue has been identified as a problem with our web service provider, which is affecting many websites including MyCase. We are implementing a solution and hope to see improvement soon.
Posted Sep 28, 2023 - 13:48 PDT
Investigating
MyCase is currently experiencing some intermittent connection issues, and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted Sep 28, 2023 - 13:36 PDT
This incident affected: MyCase.