Access to MyCase
Incident Report for MyCase - Public
Resolved
This incident has been resolved.
Posted Aug 16, 2022 - 07:42 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 16, 2022 - 06:21 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 15, 2022 - 19:52 PDT
Update
Thank you for your patience as we continue working on this issue.
Posted Aug 15, 2022 - 17:33 PDT
Update
Our Engineering team is continuing to work on a fix for this issue.
Posted Aug 15, 2022 - 16:28 PDT
Update
Thank you for your patience as we continue working through this issue.
Posted Aug 15, 2022 - 15:31 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 15, 2022 - 14:38 PDT
Monitoring
Thank you for your patience, we have identified the issue and are monitoring the situation closely.
Posted Aug 15, 2022 - 13:11 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 15, 2022 - 12:01 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 15, 2022 - 11:12 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 15, 2022 - 10:35 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 15, 2022 - 10:01 PDT
Update
We are continuing to investigate this issue.
Posted Aug 15, 2022 - 09:26 PDT
Investigating
MyCase is currently experiencing intermittent connection issues and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted Aug 15, 2022 - 08:52 PDT
This incident affected: MyCase.