Access to MyCase
Incident Report for MyCase - Public
Resolved
Our Development Team has resolved the intermittent connectivity issues. Our teams will continue to monitor.
Posted 5 months ago. Apr 05, 2019 - 08:37 PDT
Monitoring
Our Development Team has resolved the intermittent connectivity issues. Our teams will continue to monitor.
Posted 5 months ago. Apr 05, 2019 - 06:47 PDT
Investigating
MyCase is currently experiencing some intermittent connection issues, and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted 5 months ago. Apr 05, 2019 - 06:38 PDT
This incident affected: MyCase.