MyCase Slowness
Incident Report for MyCase - Public
Resolved
Our Development Team has resolved the issue. Our teams will continue to monitor. Thank you for your patience while our teams worked to resolve this.
Posted Dec 16, 2019 - 11:09 PST
Identified
MyCase is currently experiencing some slowness. Our Development Team is aware of this issue and working as quickly as possible to resolve it.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted Dec 16, 2019 - 10:58 PST
This incident affected: MyCase.