Access to MyCase
Incident Report for MyCase - Public
Resolved
This incident has been resolved.
Posted Nov 17, 2021 - 10:53 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 17, 2021 - 10:52 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 17, 2021 - 10:24 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2021 - 09:56 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 17, 2021 - 09:55 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 17, 2021 - 09:37 PST
Update
We are continuing to investigate this issue.
Posted Nov 17, 2021 - 09:30 PST
Update
We are continuing to investigate this issue.
Posted Nov 17, 2021 - 09:15 PST
Investigating
MyCase is currently experiencing connection issues and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted Nov 17, 2021 - 09:00 PST
This incident affected: MyCase.