MyCase eCheck Payments
Incident Report for MyCase - Public
Resolved
Our Development Team has resolved the issue. Thank you for your patience while this was being fixed.
Posted 7 months ago. Mar 13, 2019 - 10:59 PDT
Update
Our Development Team is continuing to work to resolve the issue as quickly as possible. Thank you for your patience, we will continue to post updates to this page.
Posted 7 months ago. Mar 13, 2019 - 10:15 PDT
Identified
We’ve identified an issue affecting our eCheck payment system. Clients are currently not able to select the eCheck payment option on the payment screen. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.
Posted 7 months ago. Mar 13, 2019 - 09:32 PDT
This incident affected: MyCase eCheck Payments.