Access to MyCase

Incident Report for MyCase - Public

Resolved

This incident has been resolved.
Posted Jun 03, 2022 - 14:01 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2022 - 13:59 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 03, 2022 - 13:56 PDT

Investigating

MyCase is currently experiencing some intermittent connection issues, and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted Jun 03, 2022 - 13:46 PDT
This incident affected: MyCase.