MyCase Experiencing Slowness
Incident Report for MyCase - Public
Resolved
Our Development Team has resolved the issue. Our teams will continue to monitor. Thank you for your patience while our teams worked to resolve this.
Posted Apr 06, 2020 - 13:32 PDT
Monitoring
MyCase is now available and our Development Team is researching any outstanding latency. Thank you for your patience while our team works to resolve this.
Posted Apr 06, 2020 - 13:18 PDT
Identified
MyCase is currently unavailable. Our team is investigating the issue and will work to restore service as soon as possible.
Posted Apr 06, 2020 - 12:58 PDT
Monitoring
Our Development Team is continuing to monitor the situation. Thank you for your patience while our team works to resolve this.
Posted Apr 06, 2020 - 12:39 PDT
Investigating
MyCase is currently experiencing degraded performance of certain features within the system resulting in slowness. Our Development Team is aware of this issue and working as quickly as possible to resolve it.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted Apr 06, 2020 - 12:15 PDT
This incident affected: MyCase.