MyCase Service Interruption

Incident Report for MyCase - Public

Resolved

This incident has been resolved.
Posted Aug 15, 2024 - 12:42 PDT

Update

We are seeing a recovery in our data center provider and MyCase service appears to be restored. We will continue to monitor to ensure resolution.
Posted Aug 15, 2024 - 12:22 PDT

Monitoring

We are seeing a recovery in our data center provider and MyCase service appears to be restored. We will continue to monitor to ensure resolution.
Posted Aug 15, 2024 - 12:19 PDT

Identified

We are seeing a recovery in our data center provider and will continue to monitor.
Posted Aug 15, 2024 - 11:58 PDT

Investigating

We are currently investigating a potential issue with our data center provider and will provide updates as soon as possible
Posted Aug 15, 2024 - 11:35 PDT
This incident affected: MyCase.