Access to MyCase
Incident Report for MyCase - Public
Resolved
The connectivity issues have been resolved and search functionality has been returned to normal operations. Please contact support@mycase.com if you encounter any issues.
Posted 9 months ago. Jan 18, 2019 - 07:37 PST
Identified
We have temporarily disabled search to mitigate the issue, fix is still ongoing. Our Development Team is working as quickly as possible to get this resolved.
Posted 9 months ago. Jan 18, 2019 - 07:05 PST
Investigating
MyCase is currently experiencing some intermittent connection issues, and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.
Posted 9 months ago. Jan 18, 2019 - 06:30 PST
This incident affected: MyCase.