Degraded Access to MyCase

Incident Report for MyCase - Public

Resolved

This incident has been resolved.
Posted Dec 07, 2021 - 15:09 PST

Update

Our service provider is making significant progress in its recovery effort. We continue to monitor the performance of MyCase.
Posted Dec 07, 2021 - 14:18 PST

Monitoring

Our service provider is continuing to see signs of recovery.
Posted Dec 07, 2021 - 12:16 PST

Update

Our service provider is continuing to see signs of recovery.
Posted Dec 07, 2021 - 11:01 PST

Update

Our service provider is starting to see some signs of recovery.
Posted Dec 07, 2021 - 10:24 PST

Update

Our service provider is continuing to work towards recovery.
Posted Dec 07, 2021 - 09:45 PST

Identified

Our service provider has identified the root cause and is actively working towards recovery.
Posted Dec 07, 2021 - 09:01 PST

Update

We are continuing to investigate this issue with the service provider causing the degraded performance of MyCase.
Posted Dec 07, 2021 - 08:44 PST

Investigating

MyCase is currently experiencing degraded performance. We are investigating the issue with one of our service providers who appears to be the root of the issue.
Posted Dec 07, 2021 - 08:16 PST
This incident affected: MyCase and MyCase Credit Card Payments.