Access to MyCase
Incident Report for MyCase - Public
Resolved
Full access to MyCase has been restored. Our teams will continue to monitor.
Posted Jul 08, 2020 - 17:05 PDT
Identified
We've identified the root cause of the issue and a fix is being implemented
Posted Jul 08, 2020 - 16:58 PDT
Investigating
MyCase is currently experiencing some connection issues, and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.
Posted Jul 08, 2020 - 16:53 PDT
This incident affected: MyCase.