Access to MyCase
Incident Report for MyCase - Public
Resolved
MyCase was experiencing intermittent connectivity issues starting at 9:30am PST. The issue has been resolved and we will continue to monitor to ensure that all customers have full access. We are sorry for any disruptions this caused you and take these issues very seriously.
Posted 6 months ago. Feb 14, 2019 - 13:17 PST
Monitoring
Full access to MyCase has been restored. Our teams will continue to monitor.
Posted 6 months ago. Feb 14, 2019 - 11:52 PST
Update
MyCase remains intermittently available as our developers continue working to resolve the issue as quickly as possible. Please check back on this page for updates.
Posted 6 months ago. Feb 14, 2019 - 11:20 PST
Update
Access to the MyCase system may be periodically disrupted. Our development team is actively working to resolve the issue as quickly as possible.
Posted 6 months ago. Feb 14, 2019 - 10:52 PST
Update
Our Development Team is continuing to research what the underlying cause is of the intermittent connectivity issues. Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted 6 months ago. Feb 14, 2019 - 10:21 PST
Investigating
MyCase is currently experiencing some intermittent connection issues, and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted 6 months ago. Feb 14, 2019 - 09:48 PST
This incident affected: MyCase.