Access to MyCase
Incident Report for MyCase - Public
Resolved
Full access to MyCase has been restored. Our teams will continue to monitor.
Posted May 06, 2020 - 08:45 PDT
Monitoring
The issue has been identified and the MyCase service is recovering.
Posted May 06, 2020 - 08:25 PDT
Update
Our Development Team is continuing to research what the underlying cause is of the intermittent connectivity issues. Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted May 06, 2020 - 08:06 PDT
Investigating
MyCase is currently experiencing some connection issues, and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted May 06, 2020 - 07:13 PDT
This incident affected: MyCase.