Our MyCase Mailbox service provider, Nylas, has updated their status page (https://status.nylas.com) to reflect the deployment of a fix for the ongoing authentication issues. We continue to be in contact with this provider to monitor the impact of the release.
Posted Feb 02, 2023 - 15:54 PST
Identified
We are still seeing some instances of degraded performance for the MyCase Mailbox feature. Our service provider, Nylas, has updated their status page (https://status.nylas.com) to reflect this. We continue to be in contact with this provider to expedite a fix and fully restore MyCase Mailbox functionality.
Posted Feb 02, 2023 - 11:48 PST
Monitoring
Our Mailbox service provider, Nylas, has recommended reauthenticating the Mailbox feature in MyCase to help resolve this issue. Please follow the steps below if you have continued to experience syncing issues between MyCase Mailbox and your email provider.
Login to MyCase and navigate to Settings > Integrations & Apps. Locate the Mailbox tile, and select Remove underneath. Once removed, refresh the tab and select Setup underneath the Mailbox tile to login to your email.
Posted Feb 02, 2023 - 07:46 PST
Identified
Our service provider, Nylas, which facilitates the syncing of emails to MyCase is experiencing connection issues. We are in contact with this provider to expedite a fix and fully restore MyCase Mailbox functionality.