Access to MyCase
Incident Report for MyCase - Public
Resolved
This incident has been resolved.
Posted Mar 01, 2022 - 08:05 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 01, 2022 - 06:50 PST
Update
We are continuing to work on a fix for this issue.
Posted Mar 01, 2022 - 06:34 PST
Identified
We've identified the root cause of the issue and a potential fix is in development for immediate release.
Posted Mar 01, 2022 - 06:04 PST
Investigating
MyCase is currently experiencing connection issues and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted Mar 01, 2022 - 05:57 PST
This incident affected: MyCase and Integrations.