Search feature
Incident Report for MyCase - Public
Resolved
The search feature in MyCase has been restored. Our Development Team will continue to monitor this situation. Thank you for your patience while the search feature was temporarily down.
Posted 5 months ago. May 06, 2019 - 10:06 PDT
Investigating
Users are currently not able to use our search feature in MyCase. We are investigating this issue and working to return functionality as soon as possible. We will update this status as more information becomes available
Posted 5 months ago. May 06, 2019 - 09:38 PDT
This incident affected: MyCase.