Access to MyCase
Incident Report for MyCase - Public
Resolved
This incident has been resolved.
Posted Apr 13, 2021 - 11:14 PDT
Monitoring
MyCase access has been restored; we will continue to monitor performance.
Posted Apr 13, 2021 - 10:24 PDT
Identified
We’re aware that MyCase is currently unavailable, our engineers are working to deploy a solution for this issue.
Posted Apr 13, 2021 - 10:01 PDT
Monitoring
We have implemented a fix and access to MyCase has been restored. We continue to monitor performance.
Posted Apr 13, 2021 - 09:39 PDT
Update
We continue working to restore service; the issue has been identified and our team is working to deploy a solution.
Posted Apr 13, 2021 - 09:31 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 13, 2021 - 08:56 PDT
Identified
Our engineers have identified the issue and we're working to restore access as soon as possible.
Posted Apr 13, 2021 - 08:56 PDT
Investigating
We experienced issues with our site this morning. Engineering is aware of the problem and working to identify the root cause. We will provide updates as soon as more information is available.
Posted Apr 13, 2021 - 08:30 PDT
This incident affected: MyCase, Integrations, Mobile Applications, MyCase eCheck Payments, MyCase Credit Card Payments, and Recent Activity, History and Notification Emails.