Degraded Access to MyCase

Incident Report for MyCase - Public

Resolved

The MyCase Calendar is now fully operational. We apologize for any inconvenience this may have caused.
Posted Mar 02, 2022 - 16:20 PST

Update

The MyCase Calendar continues to only be accessible through the MyCase Mobile App. We are planning a database reboot at 10pm PT which should help recover the MyCase Calendar for web-based usage. We apologize for the inconvenience.
Posted Mar 02, 2022 - 14:41 PST

Update

We continue to work on a fix for the MyCase Calendar feature but don't have a recovery ETA yet. The calendar can be accessed, and is functional, through the MyCase Mobile App.
Posted Mar 02, 2022 - 13:52 PST

Update

We continue to work on a fix for the Calendar feature and hope to have it resolved shortly. Thank you for your patience.
Posted Mar 02, 2022 - 12:40 PST

Update

We continue to work on a fix for the Calendar feature and hope to have it resolved shortly.
Posted Mar 02, 2022 - 11:26 PST

Update

All features of MyCase with the exception of the Calendar are fully operational. We are continuing to work on a fix for the Calendar feature.
Posted Mar 02, 2022 - 09:45 PST

Update

All features of MyCase with the exception of the Calendar are fully operational. We are currently working on a fix for the Calendar feature.
Posted Mar 02, 2022 - 08:07 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2022 - 07:38 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 02, 2022 - 07:36 PST

Investigating

We are currently investigating the root cause of the slow loading for some features of MyCase.
Posted Mar 02, 2022 - 07:25 PST
This incident affected: MyCase, Integrations, and Mobile Applications.