Outage - MyCase

Incident Report for MyCase - Public

Resolved

This incident has been resolved.
Posted Feb 24, 2020 - 21:03 PST

Monitoring

Service has been restored. We are continuing to monitor this incident.
Posted Feb 24, 2020 - 20:54 PST

Identified

The issue has been identified and the MyCase service is recovering.
Posted Feb 24, 2020 - 20:50 PST

Investigating

MyCase is currently unavailable due to an unscheduled outage. Our team is investigating the issue and will work to restore service as soon as possible.
Posted Feb 24, 2020 - 20:44 PST
This incident affected: MyCase, Integrations, Mobile Applications, MyCase eCheck Payments, MyCase Credit Card Payments, and Recent Activity, History and Notification Emails.