Access to MyCase
Incident Report for MyCase - Public
Resolved
MyCase is fully operational as of 4:28pm PST. There was a short period between 4:15pm and 4:28pm where some users may not have been able to login.
Posted about 1 year ago. Aug 13, 2018 - 16:31 PDT
Investigating
MyCase is currently experiencing some intermittent connection issues, and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted about 1 year ago. Aug 13, 2018 - 16:24 PDT
This incident affected: MyCase.