Access to MyCase
Incident Report for MyCase - Public
Resolved
Amazon has posted an update that between 7:38 AM and 9:18 AM PDT they experienced elevated API error rates and connection failures in the US-EAST-1 Region. The issue has been resolved and the service is operating normally.
Posted 12 months ago. Sep 05, 2018 - 09:34 PDT
Identified
The issues have been isolated to an Amazon SQS service that is degraded. Our team is working to mitigate.
Posted 12 months ago. Sep 05, 2018 - 08:40 PDT
Investigating
MyCase is currently experiencing some intermittent connection issues, and access to the system may be affected. Our Development Team is aware of the issue and working as quickly as possible to get this resolved.

Please check back on this page, or subscribe to updates, and we will provide an update shortly.
Posted 12 months ago. Sep 05, 2018 - 08:22 PDT