Degraded Performance: 502 Errors & Slowness

Incident Report for MyCase - Public

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 14:22 PDT

Update

We are continuing to monitor this incident with our cloud provider, AWS. The incident persists, but gradual improvement is noted with login attempts and application navigation.
Posted Oct 20, 2025 - 12:48 PDT

Update

We are continuing to monitor this incident with our cloud provider, AWS.
Posted Oct 20, 2025 - 10:54 PDT

Update

We are continuing to monitor this incident with our cloud provider, AWS.
Posted Oct 20, 2025 - 09:10 PDT

Update

We are aware of customers seeing slow response times within the MyCase app and/or increased timeouts. This is the result of an ongoing incident with our cloud provider, AWS, and we are closely monitoring the situation to restore operations to normal as quickly as we can. We appreciate your continued patience in this matter.
Posted Oct 20, 2025 - 07:37 PDT

Identified

We’re continuing to work on bringing our systems fully back on track following a major outage at our cloud provider, who are still experiencing a partial service disruption. While recovery progresses, customers may continue to experience slowness or degraded performance across parts of the system. We’ll post more updates as they become available.
Posted Oct 20, 2025 - 06:51 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 06:05 PDT

Investigating

We are currently investigating this issue.
Posted Oct 20, 2025 - 06:04 PDT
This incident affected: MyCase.