Error Logging in to MyCase
Incident Report for MyCase - Public
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 14:09 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2024 - 10:49 PST
Investigating
Some users are experiencing errors when trying to log in to their MyCase account. While we investigate and fix the issue, this login page will work successfully: https://auth.mycase.com/login_sessions/new?client_id=tCEM8hNY7GaC2c8P&response_type=code
Posted Nov 19, 2024 - 10:08 PST
This incident affected: MyCase.