MyCase Mailbox Degraded Performance
Incident Report for MyCase - Public
Resolved
This incident has been resolved and all systems are operational
Posted Jun 06, 2023 - 16:15 PDT
Monitoring
Nylas has rebuilt a key component of their infrastructure to try to mitigate the current issue. They are slowly routing traffic to it and that appears to be resolving the performance problems. We will continue monitoring and provide more updates if anything changes.
Posted Jun 06, 2023 - 14:14 PDT
Update
Nylas is still working on bringing its API service back up to resolve the performance issues. Please visit the Nylas status page for the latest updates: status.nylas.com

Thank you for your continued patience.
Posted Jun 06, 2023 - 12:06 PDT
Identified
MyCase Mailbox is currently experiencing degraded performance caused by a service interruption with our third-party service, Nylas. Please visit their status page for more details as they work to resolve this incident as quickly as possible: status.nylas.com/

Thank you for your patience; we will post any updates here as soon as we have them.
Posted Jun 06, 2023 - 11:13 PDT
This incident affected: Integrations.